Mindon.IDEA

Air off, Mind on ~ / Javascript+Golang, Sci, Health… /

Solve NodeJS 0.8+ Build Problem

NodeJS before 0.8 is very easy to make & install, which only needs OpenSSL.

But when I tried to update my NodeJS to version 0.8+, problems keep coming…

Here’s a few pre-conditions for a successful make of NodeJS v0.8+:

  1. GNU make 3.8.1+

  2. Python 2.6 or 2.7

  3. export LINK=g++ or setenv LINK g++

Do remember check these issues when you try to build new version (v0.8+) of NodeJS.

make;python;nodejs

Comments